当前位置:首页 > 问答

通达信选股公式暴涨

我来帮TA回答

求通达信 3天内涨幅超过7%的选股公式

tj:(c-ma(c,3))/ma(c,3)>=0.07;

通达信自带选股公式连涨三天?

在周期设置里添加20日线,然后在条件选股中选择新添加的20日线就可以了.

通达信选股公式 经过一段时间上涨然后跌到60周均线的 选股公式

这个行情你恐怕一只都选不出来。。。

请高手把下面的通达信公式改为有关 买点 买入 短线暴涨 绝对底部等买入信号的选股公式

选股公式的输出只能是一个,所以你以上的四个买入信号必须分四个选股公式编辑:
(一)"短线暴涨"选股公式:
MA5:=MA(C,5);
MA6:=MA(C,6);
MA10:=MA(C,10);
MA20:=MA(C,20);A2:=REF(MA20,1);J1:=(MA20-A2)/A2*100;MJ1:=MA(J1,3);
MA30:=MA(C,30);
MA60:=MA(C,60);
MA120:=MA(C,120);
乖离2:=(MA20-MA30)/MA30*100;
VAR1:=IF(BETWEEN(乖离2,-2,5),2,0);
MAX1:=MAX(MA20,MA30);
MAX2:=MAX(MAX1,MA60);
MIN1:=MIN(MA20,MA30);
MIN2:=MIN(MIN1,MA60);
K1:=(MAX2/MIN2-1)*100;{粘合度符合条件}
VAR2:=IF(K1<=8,1,0);
短线暴涨:IF(FILTER( (VAR1 OR VAR2) AND MA10>REF(MA10,1) AND COUNT(MA30>REF(MA30,1),3)=3 AND MA30>MA60 AND COUNT(CROSS(MA5,MA30),3) AND J1>MJ1 AND MA(V,5)>MA(V,60)
AND MA(V,60)>REF(MA(V,60),1),5),1,0);
(二)"买入"选股公式:
MA5:=MA(C,5);
MA6:=MA(C,6);
MA10:=MA(C,10);
MA20:=MA(C,20);A2:=REF(MA20,1);J1:=(MA20-A2)/A2*100;MJ1:=MA(J1,3);
MA30:=MA(C,30);
MA60:=MA(C,60);
MA120:=MA(C,120);
乖离2:=(MA20-MA30)/MA30*100;
VAR1:=IF(BETWEEN(乖离2,-2,5),2,0);
MAX1:=MAX(MA20,MA30);
MAX2:=MAX(MAX1,MA60);
MIN1:=MIN(MA20,MA30);
MIN2:=MIN(MIN1,MA60);
K1:=(MAX2/MIN2-1)*100;{粘合度符合条件}
VAR2:=IF(K1<=8,1,0);
买入:IF(CROSS("KDJ.K"(5,2,3),"KDJ.D"(5,2,3)) AND "KDJ.D"(5,2,3)<30 AND J1>MJ1 AND MA60>REF(MA60,1) AND COUNT(J1<1,3)>=1 ,1,0);
(三)"买点"选股公式:
MA5:=MA(C,5);
MA6:=MA(C,6);
MA10:=MA(C,10);
MA20:=MA(C,20);A2:=REF(MA20,1);J1:=(MA20-A2)/A2*100;MJ1:=MA(J1,3);
MA30:=MA(C,30);
MA60:=MA(C,60);
MA120:=MA(C,120);
乖离2:=(MA20-MA30)/MA30*100;
VAR1:=IF(BETWEEN(乖离2,-2,5),2,0);
MAX1:=MAX(MA20,MA30);
MAX2:=MAX(MAX1,MA60);
MIN1:=MIN(MA20,MA30);
MIN2:=MIN(MIN1,MA60);
K1:=(MAX2/MIN2-1)*100;{粘合度符合条件}
VAR2:=IF(K1<=8,1,0);
XL1:=((LLV(LOW,3) = LLV(LOW,60)) AND ((CLOSE / REF(CLOSE,1)) >= 1.04));
XL2:=(((CLOSE - EMA(CLOSE,21)) / EMA(CLOSE,21)) * 100);
XL3:=CROSS(XL2,(0 - 20));
买点:IF(FILTER(((XL1 > 0) AND LOW),5),1,0);
(四)"绝对底部"选股公式:
MA5:=MA(C,5);
MA6:=MA(C,6);
MA10:=MA(C,10);
MA20:=MA(C,20);A2:=REF(MA20,1);J1:=(MA20-A2)/A2*100;MJ1:=MA(J1,3);
MA30:=MA(C,30);
MA60:=MA(C,60);
MA120:=MA(C,120);
乖离2:=(MA20-MA30)/MA30*100;
VAR1:=IF(BETWEEN(乖离2,-2,5),2,0);
MAX1:=MAX(MA20,MA30);
MAX2:=MAX(MAX1,MA60);
MIN1:=MIN(MA20,MA30);
MIN2:=MIN(MIN1,MA60);
K1:=(MAX2/MIN2-1)*100;{粘合度符合条件}
VAR2:=IF(K1<=8,1,0);
XL1:=((LLV(LOW,3) = LLV(LOW,60)) AND ((CLOSE / REF(CLOSE,1)) >= 1.04));
XL2:=(((CLOSE - EMA(CLOSE,21)) / EMA(CLOSE,21)) * 100);
XL3:=CROSS(XL2,(0 - 20));
绝对底部:IF((XL3 > 0),1,0);

如何设置一个选股公式

这个条件可以选股,但有两个具体问题,第一最高价在前,还是最低价在前,第二这最近一年是一个固定的交易周期,还是真实的这一年时间,还是从今天向前推1年.
这些条件需要你确定才可以编写公式啊.

通达信软件选股的时候,怎么进行条件设置?

如何用自选公式进行选股的方法:
一、自编公式和保存:
(一)自编公式
1、打开公式管理器:点系统左上角“功能--公式系统---公式管理器”或用快捷键““Ctrl+F"键
,就能快速打开公式管理器。
2、在公式管理器上,点”条件选股公式”前面{+}展开子项目,点“其他类型-新建”;
3、在“新建”窗口,输入“公式名称”,在下面空白位置填写你刚才写的代码,点“确定”;
4、公式已经保存,编写完成。
(二)例子:
以你公式为例子,整理出符合系统要求的公式:
1、收盘价大于34日均线;
2、34日均线大于250日均线;
3、收盘价在34日均线上方5%以内;
4、成交量大于前20日均量;
M34:=MA(C,34);
M250:=MA(C,250);
TJ1:=C>M34;
TJ2:=M34>M250;
ZDJ34:=(C-REF(M34,1))/REF(M34,1)*100;
TJ3:=BETWEEN(ZDJ34,5,-5);
TJ4:=V>MA(V,20);
JPXG:(TJ1 AND TJ2 AND TJ3 AND TJ4);
二、用自选公式进行选股方法:
提示:选股前要下载完整日数据后才能进行选股:
1、点系统左上角“功能”--选股器--综合选股--其它选股,点:(自己写的)公式;
2、点“加入条件”所选公式放入“组合选投条件列表”;
3、条件设置内,选取你要求的“指定日期”;
4、点“执行选股”,符合条件个股就会自动选取出来。